Passive interface (RIP,OSPF,EIGRP)

Passive-interface command is used in all routing protocols to disable sending updates out from a specific interface. However the command behavior varies from o­ne protocol to another.

RIP:

In RIP this command will disable sending multicast updates via a specific interface but will allow listening to incoming updates from other RIP enabled neighbors.This simply means that the router will still be able to receive updates o­n that passive interface and use them in the routing table.

R1(config)# router ripR1(config-router)#  Version 2

R1(config-router)# network 10.4.0.0
R1(config-router)#  network 10.2.0.0
R1(config-router)#  passive-interface s0

The passive-interface command will prevent updates from being sent out of the Serial0 interface, but R1 will still receive updates on this interface.We can configure all interfaces to be passive using the passive-interface default command, and then individually use the no passive-interface command on the interfaces we do want updates to be sent out:

R1(config)#router rip
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface default
R1(config-router)# no passive-interface e0

EIGRP:

In EIGRP the passive-interface command stops sending outgoing hello packets, hence the router can not form any neighbor relationship via the passive interface. This behavior stops both outgoing and incoming routing updates.

R1(config)# router eigrp 10
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface s0

 

OSPF:

In OSPF the passive-interface has a similar behavior to EIGRP. The command suppresses hello packets and hence no neighbor relationships get formed.

R1(config)# router OSPF 101
R1(config-router)# network 10.4.0.0
R1(config-router)# network 10.2.0.0
R1(config-router)# passive-interface s0

Always remember, that the passive-interface command will prevent EIGRP (and OSPF) from forming neighbor relationships out of that interface. No routing updates are passed in either direction.

Important: Passive interface command applying on interfaces wont effect on the sub interfaces created under it.If you want to active “passive interface” command on sub interface,it should be given on that specific sub interface