If there are two service provider, how you will do the link load balancing in BGP?

In the multihomed environment load balancing is not an option because BGP select only one best path to destination when the BGP routes are learned from different AS’s.To achieve this we need to setup a better metric for the routers in the range 0.0.0.0 to 128.0.0.0 that are learned from ISP A and better metric for the rest of the routes that are learned from ISP B so basically we will be doing the load sharing not the load balancing.

bgp

Configuration on the Router A

interface Serial 0
ip address 162.162.162.1 255.255.255.0

interface Serial 1
ip address 161.161.161.1 255.255.255.0

router bgp 11
neighbor 161.161.161.2 remote-as 10
neighbor 161.161.161.2 route-map UPDATES-1 in

!— This allows only the networks up to 128.0.0.0.

neighbor 162.162.162.2 remote-as 12
neighbor 162.162.162.2 route-map UPDATES-2 in

!— This allows anything above the 128.0.0.0 network.

auto-summary

route-map UPDATES-1 permit 10
match ip address 1
set weight 100

route-map UPDATES-1 permit 20
match ip address 2

route-map UPDATES-2 permit 10
match ip address 1

route-map UPDATES-2 permit 20
match ip address 2
set weight 100

access-list 1 permit 0.0.0.0 127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any

Configuration on the Router B

interface Loopback0
ip address 1.1.1.1 255.255.255.0
int loopback 1
ip address 171.171.171.5 255.255.255.0

interface Serial 0
ip address 161.161.161.2 255.255.255.0

router bgp 10
neighbor 161.161.161.1 remote-as 11
network 1.0.0.0
network 171.171.0.0
auto-summary

Configuration on the Router C

interface Loopback0
ip address 172.172.172.5 255.255.255.0

interface Loopback1
ip address 2.2.2.1 255.255.255.0

interface Serial 1
ip address 162.162.162.2 255.255.255.0

router bgp 12
neighbor 162.162.162.1 remote-as 11
network 2.0.0.0
network 172.172.0.0
auto-summary


 

All-New Kindle Wifi ereader, 6″ Glare-Free Touchscreen Display at just Rs.5,999